Hilo build aka Gus 1.5ish

Re: Hilo build aka Gus 1.5ish

Postby rustynoob » Mon May 04, 2015 6:29 pm

I got it printing... sort of. It kept losing steps about two layers in... Then one of my drive belts broke. The first one I made was a bit to tight but I managed to get it on anyhow and it worked until the strain from being to tight broke the joint. I may have to give up on making my own continuous belts and but some at some point. I'll make a new belt and keep going for now. as long as I'm there to catch it when it falls I'm not too worried about it.
Joel
rustynoob.com
User avatar
rustynoob
 
Posts: 45
Joined: Mon Feb 16, 2015 3:30 am

Re: Hilo build aka Gus 1.5ish

Postby jhoff » Wed May 27, 2015 3:13 am

This is amazing! Great work!

Any chance you could make a WIP video of it in action? I'd love to see the belt working.

Awesome progress! You're gettin' me all excited about GUS again :)
jhoff
 
Posts: 6
Joined: Mon Mar 24, 2014 2:10 am

Re: Hilo build aka Gus 1.5ish

Postby rustynoob » Fri May 29, 2015 6:14 pm

My computer was waterboarded and died so I won't be able to finish things up and get a video until I replace it.
Currently I am having a problem with the firmware where it gets stuck looping a long move command and I can't edit the firmware on my phone so until my square-trade warranty comes through I'm dead in the water. I did have everything backed up so I didn't lose any work at least. I'll post a video once I get going again.
Joel
rustynoob.com
User avatar
rustynoob
 
Posts: 45
Joined: Mon Feb 16, 2015 3:30 am

Re: Hilo build aka Gus 1.5ish

Postby rustynoob » Thu Aug 27, 2015 11:19 pm

I'm back. I am working on porting the marlin firmware... like I was when my computer tried to drink a glass of water at the beginning of summer... I have an odd issue. The printer does fine for two or three layers and then starts jumping back and fourth between two points a couple of cm apart, that includes the filament extruding and retracting. I'll make a video and post it later but in the mean time does anyone have any idea what might be going wrong?
Joel
rustynoob.com
User avatar
rustynoob
 
Posts: 45
Joined: Mon Feb 16, 2015 3:30 am

Re: Hilo build aka Gus 1.5ish

Postby ekaggrat » Thu Nov 19, 2015 8:18 am

any progress?
ekaggrat
 
Posts: 56
Joined: Tue Mar 04, 2014 3:24 am

Re: Hilo build aka Gus 1.5ish

Postby rustynoob » Tue Dec 01, 2015 12:00 am

I just had some time over the long weekend to work on it some more and found that the closed loop belts I made are too unreliable after the sit for a while. The glue gets brittle the belts fall apart. I ordered some pre-made belts once I found some 270 mm belts that didn't cost $15 each. I should be able to get back to work on him some time next month. I'm uploading an old video so you all can see it in action
edit: here's the video https://youtu.be/_Dpq6rps07E
Joel
rustynoob.com
User avatar
rustynoob
 
Posts: 45
Joined: Mon Feb 16, 2015 3:30 am

Re: Hilo build aka Gus 1.5ish

Postby ekaggrat » Tue Dec 01, 2015 7:11 am

cool,
i like the belt approach. I think with a belt and a aluminum pulley the joint would be better and easier to calibrate. I dont know about the accuracy. That will only be known when you are able to get a cube printed.

:mrgreen:

edit : why not use aluminum pulley for the big pulley? The plastic printed one might induce errors as it is not as round as a aluminum one?
ekaggrat
 
Posts: 56
Joined: Tue Mar 04, 2014 3:24 am

Re: Hilo build aka Gus 1.5ish

Postby rustynoob » Sun Dec 20, 2015 3:03 am

The large plastic pulleys are big enough that I think any out of round will be negligible. for the moment I have other issues like low tolerance bolts allowing way to much flexing of the head.
If the pulley ever becomes the point where the greatest error is introduced I will replace it but I don't foresee that being an issue. yet :D
Joel
rustynoob.com
User avatar
rustynoob
 
Posts: 45
Joined: Mon Feb 16, 2015 3:30 am

Re: Hilo build aka Gus 1.5ish

Postby rustynoob » Sat Dec 26, 2015 4:35 am

I think I finally fixed the bug in my code. turns out I left out a for loop so whenever it segmented lines it broke it. I haven't had a chance to test it yet but I think tomorrow will be calibration time. I also got my belts in so I don't have to worry about them breaking all the time any more. Now I'm going to have to port my firmware modifications to the latest marlin firmware and figure out how to get them added to the marlin base.
Joel
rustynoob.com
User avatar
rustynoob
 
Posts: 45
Joined: Mon Feb 16, 2015 3:30 am

Re: Hilo build aka Gus 1.5ish

Postby ekaggrat » Fri Jan 08, 2016 7:29 am

did you get your version of marlin working?
ekaggrat
 
Posts: 56
Joined: Tue Mar 04, 2014 3:24 am

PreviousNext

Return to GUS Simpson

Who is online

Users browsing this forum: No registered users and 2 guests

cron